A fix has been implemented and we are monitoring the results
An unplanned partial outage for person Identification has been identified with our Identification service provider IDnow impacting users using web browsers to complete identification. We are working together with our provider to restore the impacted services as soon as possible.
Partner Impact:
• IDnow identification attempts would reflect ‘Pending’ state for identifications triggered via WEB • IDnow identification attempts via the mobile applications should work as expected
Customer Impact:
• Customers initiating new IDnow identifications may experience delays or interruptions in completing the process when triggered via web • It is recommended to initiate identifications via the Mobile App
API Reference Documentation: To understand more about the impacted services please read the following public documentation:
We apologize for any inconveniences this outage may have caused. In case of any questions or concerns, please contact us by sending an email at incidents@solarisgroup.com or through our dedicated ticketing platform.
Posted Mar 19, 2025 - 10:48 CET
Identified
An unplanned partial outage for person Identification has been identified with our Identification service provider IDnow impacting users using web browsers to complete identification. We are working together with our provider to restore the impacted services as soon as possible.
Partner Impact:
• IDnow identification attempts would reflect ‘Pending’ state for identifications triggered via WEB • IDnow identification attempts via the mobile applications should work as expected
Customer Impact:
• Customers initiating new IDnow identifications may experience delays or interruptions in completing the process when triggered via web • It is recommended to initiate identifications via the Mobile App
API Reference Documentation: To understand more about the impacted services please read the following public documentation:
We apologize for any inconveniences this outage may have caused. In case of any questions or concerns, please contact us by sending an email at incidents@solarisgroup.com or through our dedicated ticketing platform.
Posted Mar 18, 2025 - 18:22 CET
Investigating
An unplanned partial outage for person Identification IDnow services has been identified. We are working together with our vendor to restore the impacted services as soon as possible.
Partner Impact: • IDnow identification attempts remain stuck in ‘Pending’ state as observed in WebUI. No API errors are known to be returned.
Customer Impact: • Customers initiating new IDnow identifications may experience delays or interruptions in having the process completed.
API Reference Documentation: To understand more about the impacted services please read the following public documentation:
We apologize for any inconveniences this outage may have caused. In case of any questions or concerns, please contact us by sending an email at incidents@solarisgroup.com or through our dedicated ticketing platform.