Partial Outage for Card Control Services and Card Authorizations

Incident Report for Solaris

Resolved

The incident affecting Card Transactions and Card Control Services was resolved. A fix was applied to resolve the performance issues and all services were confirmed to be working under normal circumstances.

Partner Impact Resolution:
• Partners no longer receive increased 5XX HTTP error rates for the Card Control API Endpoints and increased reports in number of card transaction Declines.

Customer Impact Resolution:
• Customers no longer receive unexpected card transaction declines with unknown reason.
• Management of Card Control operations such as creating or deleting card spending limits is now possible.

Previously Affected endpoints:
• GET /v1/card_controls/lists
• GET /v1/card_controls/lists/spending_limits/{id}
• POST /v1/card_controls/spending_limits
• POST /v1/card_controls/lists
• GET /v1/card_controls/spending_limits
• DELETE /v1/card_controls/lists/spending_limits/{id}
• DELETE /v1/card_controls/lists{id}

(Downstream dependent API services may have been also affected)

API Reference Documentation: To understand more about the impacted endpoints please read the following public documentation:
https://docs.solarisgroup.com/api-reference/digital-banking/cards/#tag/Card-spending-controls

In case of any questions or concerns, please contact us by sending an email at incidents@solarisbank.de or through our dedicated ticketing platform.
Posted Sep 19, 2023 - 12:09 CEST

Identified

Additional impact has been reported to be affecting Card Transactions, in addition to Card Control Services. Customers experienced unexpected card declines during the outage window. We are investigating the new reports of issues and are coordinating with our Card Processing provider to ensure service stability for all affected services.

Partner Impact:
• Partners would have received increased 5XX HTTP error rates for the Card Control API Endpoints listed below and increased reports in number of card transaction Declines.

Customer Impact:
• Customers received unexpected card transaction declines (such as insufficient funds when enough funds were available).
• Management of Card Control operations such as creating or deleting card spending limits was unavailable during the outage duration for customers.

Affected endpoints:
• GET /v1/card_controls/lists
• GET /v1/card_controls/lists/spending_limits/{id}
• POST /v1/card_controls/spending_limits
• POST /v1/card_controls/lists
• GET /v1/card_controls/spending_limits
• DELETE /v1/card_controls/lists/spending_limits/{id}
• DELETE /v1/card_controls/lists{id}

(Downstream dependent API services may have been also affected)

API Reference Documentation: To understand more about the impacted endpoints please read the following public documentation:
https://docs.solarisgroup.com/api-reference/digital-banking/cards/#tag/Card-spending-controls

We apologize for any inconveniences this outage may have caused. In case of any questions or concerns, please contact us by sending an email at incidents@solarisbank.de or through our dedicated ticketing platform.
Posted Sep 18, 2023 - 17:12 CEST

Monitoring

A minor disruption has been identified to have impacted Card Control services on 18th of September 2023 between 13:53 - 13:56 CET. Services have recovered and are currently being monitored for stability.

Partner Impact:
• Partners would have received increased 5XX HTTP error rates for the Card Control API Endpoints listed below.

Customer Impact:
• Management of Card Control operations such as creating or deleting card spending limits was unavailable during the outage duration for customers.

Affected endpoints:
• GET /v1/card_controls/lists
• GET /v1/card_controls/lists/spending_limits/{id}
• POST /v1/card_controls/spending_limits
• POST /v1/card_controls/lists
• GET /v1/card_controls/spending_limits
• DELETE /v1/card_controls/lists/spending_limits/{id}
• DELETE /v1/card_controls/lists{id}

(Downstream dependent API services may have been also affected)

API Reference Documentation: To understand more about the impacted endpoints please read the following public documentation:
https://docs.solarisgroup.com/api-reference/digital-banking/cards/#tag/Card-spending-controls

We apologize for any inconveniences this outage may have caused. In case of any questions or concerns, please contact us by sending an email at incidents@solarisbank.de or through our dedicated ticketing platform.
Posted Sep 18, 2023 - 14:43 CEST
This incident affected: Cards.