Service Disruption Notice: Physical Visa Card Production Delayed

Incident Report for Solaris

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2026 - 17:34 CEST

Identified

Dear Partners,

We are experiencing a delay in card delivery.

Partner & Customer Impact:

• Customers might experience 2-3 days delays with physical Visa cards deliveries.

Impacted Services:

• Physical Visa Card Production

Disclaimer: Actual customer impact experience may vary, depending on each Partner's implementation of Solaris API services.

In case of any questions or concerns, please contact us by sending an email at incidents@solarisgroup.com or through our dedicated ticketing platform.
Posted Jun 18, 2026 - 17:41 CEST
This incident affects: Cards.