Unplanned IDNOW Partial Outage - Identity Service

Incident Report for Solaris

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 18:08 CET

Identified

An unplanned partial outage affecting person identification via IDnow services has been identified. We are working together with our vendor to restore the impacted services as soon as possible.

Partner Impact:
• IDnow identification attempts remain stuck in ‘Pending’ state as observed in WebUI and API

Customer Impact:
• Customers initiating new IDnow identifications may experience delays or interruptions in completing the process.

API Reference Documentation: To understand more about the impacted services, please read the following public documentation:

https://docs.solarisgroup.com/guides/kyc/videoident/#video-identification-via-idnow

We apologize for any inconvenience this outage may have caused. In case of any questions or concerns, please contact us by sending an email to incidents@solarisgroup.com or through our dedicated ticketing platform.
Posted Dec 03, 2025 - 15:57 CET
This incident affected: Identification.