Unplanned Degraded Performance for a subset of API Endpoints
Incident Report for Solaris
Resolved
The fix applied for the unplanned degraded performance for a subset of API endpoints between ~14:30 - 18:03 CET on 1st of March 2024 has been monitored and all operations are running within normal service levels.

Partner Impact:

• Identified API endpoints related to Card Controls and obtaining account reservations information returned intermittent 504/502 HTTP error messages during the incident duration.

Customer Impact:

• Customers performing operations related to Cards Controls and Reservation account information retrieval API services were presented intermittently with error messages during the incident window.

Impacted endpoints:

• GET /v1/accounts/{account_id}/reservations
• GET /v1/card_controls/spending_limits/{id}
(Please note that the list of services and API endpoints is not exhaustive)

API Reference Documentation: To understand more about the impacted endpoints please read the following public documentation:

https://docs.solarisgroup.com/api-reference/digital-banking/cards/#operation/indexCardControlSpendingLimit
https://docs.solarisgroup.com/api-reference/digital-banking/account-management/#tag/Reservations/paths/~1v1~1accounts~1{account_id}~1reservations/get

We apologize for any inconveniences this outage may have caused. In case of any questions or concerns, please contact us by sending an email at incidents@solarisbank.de or through our dedicated ticketing platform.
Posted Mar 01, 2024 - 19:10 CET
Monitoring
An unplanned degraded performance incident for a subset of API endpoints has been identified between ~14:30 - 18:03 CET on 1st of March 2024. A fix has been applied and services are being monitored in order to ensure all operations are running within normal service levels.

Partner Impact:

• Identified API endpoints related to Card Controls and obtaining account reservations information returned intermittent 504/502 HTTP error messages during the incident duration.

Customer Impact:

• Customers performing operations related to Cards Controls and Reservation account information retrieval API services were presented intermittently with error messages during the incident window.

Impacted endpoints:

• GET /v1/accounts/{account_id}/reservations
• GET /v1/card_controls/spending_limits/{id}
(Please note that the list of services and API endpoints is not exhaustive)

API Reference Documentation: To understand more about the impacted endpoints please read the following public documentation:

https://docs.solarisgroup.com/api-reference/digital-banking/cards/#operation/indexCardControlSpendingLimit
https://docs.solarisgroup.com/api-reference/digital-banking/account-management/#tag/Reservations/paths/~1v1~1accounts~1{account_id}~1reservations/get

We apologize for any inconveniences this outage may have caused. In case of any questions or concerns, please contact us by sending an email at incidents@solarisbank.de or through our dedicated ticketing platform.
Posted Mar 01, 2024 - 18:38 CET
This incident affected: Cards and Digital Banking.